Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam
  •      Sign In   
  • Create Account

Did you vote today?

Did you know we depend on your votes? Please Vote! http://goo.gl/RsLpq Vote Often!


Photo

Allocate More Memory To Minecraft

minecraft memory memory ram

  • Please log in to reply
76 replies to this topic

#1 BasicEgg

BasicEgg

    Chicken

  • Diplomats
  • PipPip
  • 17 posts

Posted 07 June 2011 - 08:18 AM

MAYBE ITS THE SERVER

TRY MUTTSWORLD OUT!

 

http://muttsworldmine.com

 

 

How to allocate more memory into Minecraft


(give minecraft more memory)(Windows only)

What are you running now?

You need to know if you are running a 64 bit or 32 bit windows. You can check it by following these steps:

1) Press Start -> Settings -> Control Panel
2) Double click on System

This opens a window like this:

example1t.png

Check the memory (RAM) being used and the system type. You will need it for later!

I know how much memory (RAM) is being used and my system type

Good job! Now follow these steps:

1) Open a .txt file on your desktop by right clicking on your desktop -> New -> Text Document
2) Open the txt file to edit it.
3) Depending on how many RAM you have you copy the following into the Text Document:
Warning do NOT allocate more then you have on Memory (RAM)!

I want to allocate 2GB RAM
javaw -Xmx2048m -Xms1024m -jar "C:\<your minecraft directory\Minecraft.exe"

I want to allocate 3GB RAM
javaw -Xmx3072m -Xms1536m -jar "C:\<your minecraft directory\Minecraft.exe"

I want to allocate 4GB RAM
javaw -Xmx4096m -Xms2048m -jar "C:\<your minecraft directory\Minecraft.exe"

I want to allocate 5GB RAM
javaw -Xmx5120m -Xms2560m -jar "C:\<your minecraft directory\Minecraft.exe"

I want to allocate 6GB RAM
javaw -Xmx6144m -Xms3072m -jar "C:\<your minecraft directory\Minecraft.exe"

I want to allocate 7GB RAM
javaw -Xmx7168m -Xms3584m -jar "C:\<your minecraft directory\Minecraft.exe"

I want to allocate 8GB RAM
javaw -Xmx8192m -Xms4096m -jar "C:\<your minecraft directory\Minecraft.exe"

Example: I want to use 3GB of RAM for my Minecraft cause my computer has 4GB of RAM and I like to have background programs running. I’m using this exact string (see that I filled in my Minecraft directory !)

javaw -Xmx3072m -Xms1536m -jar "C:\Users\Sonny\Desktop\Games\Minecraft.exe"

example3p.png

4) In Notepad you can now click File -> Save As…-> and change the .txt to .bat

example2g.png

5) Soon as you did that you double click the .bat file and voila Minecraft will run with more allocated memory

Troubleshooting:

Windows 64 bit:
Don't give up yet ! It didn’t work because you do not have (the correct version of) Java installed. You can download the correct version of Java at: http://java.com/en/download/manual.jsp

Don’t worry you can have 64-bit and 32-bit version of Java installed at the same time.

Windows 7 (any version)
You copied everything to the txt file but the first X's are small x's. Make sure your -Xmx####m and -Xms####m are upper-cased.

*Thanks to Vydaera*

What does Xmx and Xms mean?

Xmx is maximum memory allocated
Xms is initial memory allocated
Your Xmx will never be reached (max is around 1024mb, before dump) and your Xms is the ammount being available for direct usage.

 

 

MAYBE ITS THE SERVER

TRY MUTTSWORLD OUT!

 

http://muttsworldmine.com



#2 Smokey42356

Smokey42356

    Zombie

  • Diplomats
  • PipPipPipPipPipPip
  • 164 posts
  • LocationLongview TX
  • Players Head: :

    Smokey42356

Posted 07 June 2011 - 08:40 AM

so i did that and i get a message saying that it could not find the main class

#3 Vydaera

Vydaera

    Spider

  • Diplomats
  • PipPipPipPipPip
  • 118 posts
  • LocationArcadia
  • Players Head: :

    Vydaera

Posted 07 June 2011 - 08:51 AM

I had that same problem at first.

Make sure your -Xmx####m and -Xms####m are upper-cased, just like that.

javaw -Xmx2048m -Xms1024m -jar "C:\Users\Vydaera\Desktop\Minecraft.exe"

i hate brownbiscuit

do me


#4 mumblerit

mumblerit

    MuttsWorld Extravaganzor

  • Administrators
  • 2,328 posts
  • Players Head: :

    mumblerit

Posted 07 June 2011 - 06:38 PM

32 bit windows users cannot allocate more then 2gb to java

yQkaVeM.gif


#5 838808

838808

    Numbers

  • Diplomats
  • PipPipPip
  • 35 posts
  • LocationDenver, Colorado
  • Players Head: :

    838808

Posted 07 June 2011 - 09:59 PM

thanks Rick

~Teh Numbers~

Tnl3p.jpg

B&hammer
Album: #'s Alpha
1 images
0 comments


#6 Zhalfir

Zhalfir

    Zombie

  • Diplomats
  • PipPipPipPipPipPip
  • 188 posts
  • Players Head: :

    Zhalfir

Posted 07 June 2011 - 11:16 PM

I had that same problem at first.

Make sure your -Xmx####m and -Xms####m are upper-cased, just like that.

javaw -Xmx2048m -Xms1024m -jar "C:\Users\Vydaera\Desktop\Minecraft.exe"

I get the same message as Smokey, both are capitalized.

Edit: Copy/pasted what you had, changing the file location to mine and it worked, weird.

#7 Vydaera

Vydaera

    Spider

  • Diplomats
  • PipPipPipPipPip
  • 118 posts
  • LocationArcadia
  • Players Head: :

    Vydaera

Posted 08 June 2011 - 08:23 AM

The (-) symbols that Rick used in the example memory configs are WRONG. They are a long dash, probably copy + pasted from another doc. You need to delete those, and put in your OWN (-) symbols, otherwise you'll get an error.

i hate brownbiscuit

do me


#8 mumblerit

mumblerit

    MuttsWorld Extravaganzor

  • Administrators
  • 2,328 posts
  • Players Head: :

    mumblerit

Posted 08 June 2011 - 09:54 AM

The (-) symbols that Rick used in the example memory configs are WRONG. They are a long dash, probably copy + pasted from another doc. You need to delete those, and put in your OWN (-) symbols, otherwise you'll get an error.


fail rick with his foreign dashes

yQkaVeM.gif


#9 ojmt999

ojmt999

    Mod

  • Survival Mod
  • 946 posts
  • LocationLondon/Bristol
  • Players Head: :

    ojmt999

Posted 08 June 2011 - 01:15 PM

ty rick/vydaeara using excatly the same settings i can now get 70-90 fps as opposed to 30-50 tyyyyy

#10 Guest_jake_*

Guest_jake_*
  • Guests

Posted 03 July 2011 - 11:01 AM

it keeps sayin that it cant access the jar file

#11 mumblerit

mumblerit

    MuttsWorld Extravaganzor

  • Administrators
  • 2,328 posts
  • Players Head: :

    mumblerit

Posted 03 July 2011 - 11:15 AM

when you do this you need to download the linux .jar file or run it inside the .minecraft/bin folder

yQkaVeM.gif


#12 takodaman

takodaman

    Spider

  • Members
  • PipPipPipPipPip
  • 83 posts
  • Locationnone of your business, NV

Posted 08 July 2011 - 11:07 PM

i was looking at this on my phone so i put everything maually and i believe it worked it was about to show one of those black command things then it went away no error or anything so i believe it worked
Posted Image

-thanks for listening to my rant takodaman
by the time you figure it out this says nothing its to late to stop reading

#13 mumblerit

mumblerit

    MuttsWorld Extravaganzor

  • Administrators
  • 2,328 posts
  • Players Head: :

    mumblerit

Posted 09 July 2011 - 03:51 PM

i was looking at this on my phone so i put everything maually and i believe it worked it was about to show one of those black command things then it went away no error or anything so i believe it worked


add the word pause to the end of the script, this will allow you to see what happened and why minecraft didnt start

yQkaVeM.gif


#14 Vydaera

Vydaera

    Spider

  • Diplomats
  • PipPipPipPipPip
  • 118 posts
  • LocationArcadia
  • Players Head: :

    Vydaera

Posted 10 July 2011 - 12:02 PM

If you're getting a 'Command not found' error, or your console window just closes without doing anything, it could be that you need to set your PATH for Java. Here's how:

Setting Path on Windows
For Windows XP:

Start -> Control Panel -> System -> Advanced
Click on Environment Variables, under System Variables, find PATH, and click on it.
In the Edit windows, modify PATH by adding the location of the class to the value for PATH. If you do not have the item PATH, you may select to add a new variable and add PATH as the name and the location of the class as the value.
Close the window.
Reopen Command prompt window, and run your java code.


For Windows Vista:

Right click “My Computer” icon
Choose “Properties” from context menu
Click “Advanced” tab (“Advanced system settings” link in Vista)
In the Edit windows, modify PATH by adding the location of the class to the value for PATH. If you do not have the item PATH, you may select to add a new variable and add PATH as the name and the location of the class as the value.
Reopen Command prompt window, and run your java code.

Stolen directly from the Java website. Thanks Sun Microsystems!

i hate brownbiscuit

do me


#15 gamemaster1494

gamemaster1494

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 13 July 2011 - 11:07 PM

It keeps telling me Could Not Create The Java Virtual Machine

#16 Dragonshear

Dragonshear

    Ghast

  • Survival Mod
  • 1,733 posts
  • LocationAmerica
  • Players Head: :

    Dragonshear

Posted 14 July 2011 - 09:34 PM

My computer only has 2GB of ram.
What do.
How do this.

dragonshear2.jpg

LOLWAT_zps9088ef3a.png


#17 mumblerit

mumblerit

    MuttsWorld Extravaganzor

  • Administrators
  • 2,328 posts
  • Players Head: :

    mumblerit

Posted 15 July 2011 - 11:13 PM

It keeps telling me Could Not Create The Java Virtual Machine


how much ram is on your computer, you may want to work in the 512M range

yQkaVeM.gif


#18 jhedrick83

jhedrick83

    Chicken

  • Diplomats
  • PipPip
  • 13 posts

Posted 16 July 2011 - 09:08 AM

Awesome guys, Thanks!

#19 homeboi

homeboi

    Chicken

  • Members
  • PipPip
  • 15 posts
  • LocationEarth

Posted 29 July 2011 - 02:33 AM

If it's still not working for you try copy paste this into the .txt: java -Xms650m -jar "C:\Documents and Settings\<UserName>\Desktop\minecraft.exe
*make sure u replace the <username> with your username.
*press F3 and look to make sure that the allocated memory and used memory are changed
*you can add more memory by simply typing it -Xms(here)m .

and you are ready to go :D

#20 jumpsx14

jumpsx14

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 03 August 2011 - 12:14 PM

when i open the .bat file i keep getting popup that says:

unable to access jarfile C:\<your minecraft directory\Minecraft.exe

what does that mean and how can i fix it?

#21 takodaman

takodaman

    Spider

  • Members
  • PipPipPipPipPip
  • 83 posts
  • Locationnone of your business, NV

Posted 03 August 2011 - 09:45 PM

u dont type <yourminecraftdirectory> you actually out the path to your minecraft directory so you probably dont do much with the properties files on mods do you and i bet you say that many commands arent working do you
Posted Image

-thanks for listening to my rant takodaman
by the time you figure it out this says nothing its to late to stop reading

#22 jumpsx14

jumpsx14

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 03 August 2011 - 11:58 PM

yea really i am pretty inept with computers. im slowly learning. ive realized i need to type in the directory, but i havnt got the foggiest how! ive tried everything. ive went to forums, watched videos, but have no idea how to type my miecraft directory. it always says that it cannot be found.
my minecraft is saved to my desktop. so i put in:
javaw -Xmx8192m -Xms4096m -jar "C:\User\Owner\Desktop\Minecraft.exe"
ive tried like 20 different things and for f#cks sake they dont work. can somebody please just tell me how to find out the minecraft directory is please? Very much appreciated :)

#23 Vydaera

Vydaera

    Spider

  • Diplomats
  • PipPipPipPipPip
  • 118 posts
  • LocationArcadia
  • Players Head: :

    Vydaera

Posted 05 August 2011 - 01:35 AM

Right-click on the icon, go to properties. You should see a field labeled "Location". Just copy and paste that, add \minecraft.exe and it should work. And make sure to use a \, not a /.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

u dont type <yourminecraftdirectory> you actually out the path to your minecraft directory so you probably dont do much with the properties files on mods do you and i bet you say that many commands arent working do you


I ran this through google translate... nothing came up. Can you repost in english please?

i hate brownbiscuit

do me


#24 ojmt999

ojmt999

    Mod

  • Survival Mod
  • 946 posts
  • LocationLondon/Bristol
  • Players Head: :

    ojmt999

Posted 24 August 2011 - 11:06 AM

When i use spoutcraft, how would i allocate more memory to that?

#25 ppaco

ppaco

    [muhreen]

  • Diplomats
  • PipPipPipPipPipPipPip
  • 499 posts
  • Players Head: :

    ppaco

Posted 28 August 2011 - 07:42 AM

When i use spoutcraft, how would i allocate more memory to that?


Replace the ending with Spout's location and spouts executable file.
I'm on my level

#26 josborn8

josborn8

    Chicken

  • Survival Mod
  • 17 posts
  • LocationKnoxville
  • Players Head: :

    josborn8

Posted 08 September 2011 - 10:54 PM

"C:\User\Owner\Desktop\Minecraft.exe"


C:\User probably doesn't exist. Try C:\Users\Owner\Desktop\Minecraft.exe if that is where you downloaded minecraft to.

Right-click on the icon, go to properties. You should see a field labeled "Location". Just copy and paste that, add \minecraft.exe and it should work. And make sure to use a \, not a /.


Or, do that.

I ran this through google translate... nothing came up. Can you repost in english please?


I second this request.

#27 Josh Zahrte

Josh Zahrte

    Newbie

  • Members
  • Pip
  • 1 posts
  • Players Head: :

    Sylentwolf8

Posted 09 September 2011 - 03:37 PM

Alright so I successfully managed to change the memory usage, however now it won't let me login to the game and I can only play in offline mode. Any suggestions?

#28 mumblerit

mumblerit

    MuttsWorld Extravaganzor

  • Administrators
  • 2,328 posts
  • Players Head: :

    mumblerit

Posted 09 September 2011 - 04:07 PM

thats really odd..

yQkaVeM.gif


#29 Vydaera

Vydaera

    Spider

  • Diplomats
  • PipPipPipPipPip
  • 118 posts
  • LocationArcadia
  • Players Head: :

    Vydaera

Posted 10 September 2011 - 06:30 AM

Alright so I successfully managed to change the memory usage, however now it won't let me login to the game and I can only play in offline mode. Any suggestions?


What error does it give you when you try to log in?

All you're doing is increasing the amount of memory your computer dedicates to Minecraft through Java... it shouldn't have any effect on your ability to join servers.

i hate brownbiscuit

do me


#30 Yorktheman

Yorktheman

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 15 September 2011 - 08:01 AM

Hey guys, I'm running into some problems. I get this "Could not create Java Virtual Machine"? I'm on win7 32-bit 4gb of ram and I only want to allocate 2gb as apposed to 495mb. this is the code i was trying to use [ javaw -Xmx2048mm -Xms1024m -jar "C:\Users\******\Desktop\Minecraft.exe" ] Thanks!





Similar Topics Collapse